Discussion:
help compiling gcc-10.2 on ubuntu 20.04
(too old to reply)
nail el jaouari
2020-09-15 09:39:18 UTC
Permalink
Hello,

As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.

So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the

packages, I applied the debian patch by issuing the command:

debian/rules patch

but I get the error

make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1

thanks.
Jonathan N. Little
2020-09-15 13:34:23 UTC
Permalink
Post by nail el jaouari
Hello,
As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.
So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the
 debian/rules patch
but I get the error
make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1
Maybe use a ppa instead

<https://launchpad.net/~ubuntu-toolchain-r/+archive/ubuntu/test>
--
Take care,

Jonathan
-------------------
LITTLE WORKS STUDIO
http://www.LittleWorksStudio.com
nail el jaouari
2020-09-16 08:21:58 UTC
Permalink
Post by Jonathan N. Little
Post by nail el jaouari
Hello,
As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.
So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the
 debian/rules patch
but I get the error
make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1
Maybe use a ppa instead
<https://launchpad.net/~ubuntu-toolchain-r/+archive/ubuntu/test>
never mind!
Now I downloaded gcc-10-source_10.2.0-8ubuntu1_all.deb and extracted it.
Applying the patch is without issue!
I was doing it the wrong the way.

Thanks
Big Bad Bob
2020-09-16 05:39:59 UTC
Permalink
Post by nail el jaouari
Hello,
As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.
So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the
 debian/rules patch
but I get the error
make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1
thanks.
can you install a -source package for gcc? The build instructions for
-source packages are well documented. It's been a while since I did it
[I had to modify some avr-gcc avr-libc and avr-binutils stuff for a
newer CPU that's now supported upstream, for an earlier version of Ubu
and Debian] but I used the -source packages and went from there. it's
also good to use them as you'll get the dependency -dev packages loaded,
too.

Hope this helps.
--
(aka 'Bombastic Bob' in case you wondered)

'Feeling with my fingers, and thinking with my brain' - me

'your story is so touching, but it sounds just like a lie'
"Straighten up and fly right"
nail el jaouari
2020-09-16 08:23:16 UTC
Permalink
Post by nail el jaouari
Hello,
As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.
So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the
  debian/rules patch
but I get the error
make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1
thanks.
can you install a -source package for gcc?  The build instructions for
-source packages are well documented.  It's been a while since I did it
[I had to modify some avr-gcc avr-libc and avr-binutils stuff for a
newer CPU that's now supported upstream, for an earlier version of Ubu
and Debian] but I used the -source packages and went from there.  it's
also good to use them as you'll get the dependency -dev packages loaded,
too.
Hope this helps.
never mind!
Now I downloaded gcc-10-source_10.2.0-8ubuntu1_all.deb and extracted it.
Applying the patch is without issue!
I was doing it the wrong the way.

Thanks

Big Bad Bob
2020-09-16 05:40:24 UTC
Permalink
Post by nail el jaouari
Hello,
As the title says, I want to compile gcc 10.2 on my linux ubuntu 20.04.
So I downloaded gcc-10.2.0.tar.xz and the patch
gcc-10_10.2.0-8ubuntu1.debian.tar.xz. After extracting the
 debian/rules patch
but I get the error
make: *** [debian/rules.patch:301: stamps/02-patch-stamp] Error 1
thanks.
oh should have mentioned "apt get source" - I think that's right.
--
(aka 'Bombastic Bob' in case you wondered)

'Feeling with my fingers, and thinking with my brain' - me

'your story is so touching, but it sounds just like a lie'
"Straighten up and fly right"
Continue reading on narkive:
Loading...